因使用旧版 jQuery,全球至少有 7.5 亿个网站存在安全风险

11 月 6 日消息,OpenJS 基金会日前在官网声称,基于 IDC 调查结果,在全球 19 亿个网站中,近 90% 使用开源软件 jQuery,其中至少有 7.5 亿个网站正在使用旧版 jQuery,超过三分之一的受访者证实在过去 24 个月内经历了相关“安全事件”。

因使用旧版 jQuery,全球至少有 7.5 亿个网站存在安全风险插图

▲ 图源 OpenJS 基金会

OpenJS 基金会表示:

  • 89%的随机调查受访者报告称,他们知道自己的网站使用了 jQuery。
  • 85%的受访者认为,自家企业拥有网站是极其重要的。
  • 安全事件造成的业务损失严重,28%的受访者表示有客户流失,29%的受访者表示造成了收入损失。此外 45% 的受访者报告了因安全事件导致了自家品牌受损。
  • 48% 的受访者表示,提升安全性是他们升级 jQuery 的首要动机。

OpenJS 基金会认为,企业主和开发人员有责任确保其网站安全,虽然 jQuery 使网页开发变得更为方便,但也许多网站依然沿用旧的 jQuery 版本,这些版本中或多或少存在安全漏洞,即使 jQuery 团队发布针对性的安全修复,这些网站通常也不会进行更新,从而导致一系列“安全事件”。

worbler.ai 的 jQuery Core 团队负责人兼首席前端工程师 Timmy Willison 表示,“每个人都有责任确保自己的网站安全。这并不总是一项简单的任务,但确保软件包是最新的可能是一个很好的开始,jQuery 团队很高兴与 OpenJS 基金会合作,作为这项‘网络检查活动’的一部分,从而帮助改善一系列网站的安全状况。”

OpenJS 基金会正在评估旗下 OpenJS Healthy Web 检查工具,IT之家发现,这款工具主要用于检测网站上的软件包是否过时,目前相关工具正处于测试阶段,仅限技术评估人员和 OpenJS 成员使用,计划于 2024 年初全面推出。

声明:本站所有文章,如无特殊说明或标注,均为本站原创发布。任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。如若本站内容侵犯了原著者的合法权益,可联系我们进行处理。

给TA打赏
共{{data.count}}人
人已打赏
个人中心
购物车
优惠劵
搜索