PHP爆严重漏洞:可远程执行任意代码 请尽快更新!

6 月 8 日消息,PHP 项目维护团队昨日发布新补丁,修复了存在于 PHP for Windows 中的远程代码执行(RCE)漏洞,并敦促用户尽快更新至 6 月 6 日发布的 8.3.8、8.2.20 以及 8.1.29 版本。

PHP 是一种广泛使用的开放源码脚本语言,设计用于网络开发,通常在 Windows 和 Linux 服务器上使用。

Devcore 首席安全研究员 Orange Tsai 于 2024 年 5 月 7 日发现了这个新的 RCE 漏洞,并将其报告给了 PHP 开发人员。

该漏洞追踪编号为 CVE-2024-4577,影响到自 5.x 版以来的所有版本,可能对全球大量服务器造成影响。

PHP爆严重漏洞:可远程执行任意代码 请尽快更新!插图

此外 Shadowserver 基金会发布公告,表示已经检测到有黑客正扫描存在该漏洞的服务器。

ITCVE-2024-4577 漏洞是由于处理字符编码转换时的疏忽造成的,在 Windows 上以 CGI 模式使用 PHP,尤其是使用 “Best-Fit”功能的服务器环境,比较容易遭到黑客攻击。

DevCore 的咨询解释说:

在实施 PHP 时,团队没有注意到在 Windows 操作系统内进行编码转换的 Best-Fit 功能。

未经认证的攻击者利用该漏洞,通过特定字符序列绕过 CVE-2012-1823 先前的保护。通过参数注入攻击,可在远程 PHP 服务器上执行任意代码。

分析人员解释说,即使 PHP 未配置为 CGI 模式,只要 PHP 可执行文件(如 php.exe 或 php-cgi.exe)位于网络服务器可访问的目录中,CVE-2024-4577 仍有可能被利用。

声明:本站所有文章,如无特殊说明或标注,均为本站原创发布。任何个人或组织,在未征得本站同意时,禁止复制、盗用、采集、发布本站内容到任何网站、书籍等各类媒体平台。如若本站内容侵犯了原著者的合法权益,可联系我们进行处理。

给TA打赏
共{{data.count}}人
人已打赏
个人中心
购物车
优惠劵
搜索